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KompoZer User Guide 

1    Introduction  

KompoZer is a complete Web Authoring System which integrates web page development 
and web file management. It provides a web page editor which has a simple graphical 
(wysiwyg – what you see is what you get) interface. With KompoZer, newcomers will quickly 
and easily be able to produce new web pages. 

KompoZer incorporates a Site Manager this gives rapid access to the files on both local 
machines and remote servers. It can cater for several sites and switch rapidly between them. 

From within KompoZer pages and associated files may be uploaded to a remote server. 

KompoZer supports the use of “Styles” through Cascading Style sheets (CSS) both 
embedded and external. It has an editor which generates CSS code conforming with CSS 2.1 
specifications. 

2    Quick start 

2.1 Preliminary 

Open KompoZer 

The main window opens. At the top are a number of toolbars. The topmost is the Menu 
Bar. This carries a number of items (File, Edit etc) used to make selections. The next is the 
‘Composition Toolbar’ which carries a number of ‘Buttons’ labelled ‘New’, ‘Open’ etc. 

2.2    To create a new page: 

On the Composition toolbar Click the ‘New’ button. 

2.3    To open an existing page 

Assuming that the page is stored on your local disk in HTML format: 

On the menu Bar click ‘File’ then ‘Open File’. Browse to the file and click ‘Open’. 

2.4    Editing a web page 

Your web page – blank or otherwise – is in the large pane in the centre right of the 
KompoZer application window. Many editing functions are very similar to those in a word 
processor. The top four toolbars on the KompoZer application window provide a number 
of editing functions – to see what any do hover the cursor over an item and a hint will 
appear. 
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2.5    Saving a Page 

To save a page: 

On the Composition toolbar click ‘Save’.  

If it was a new document a dialog window will ask you to enter a title for the page. This will 
appear in the tab at the top of the page display area. NB this is NOT the file name. Click 
‘OK’; you will then be offered a normal save window which allows you to browse to a 
suitable location and name the file. The file extension offered will be HTML. 

2.6    Browsing a page  

To see how your page will look in your default browser on the Composition toolbar click 
‘Browse’. 

3    Using KompoZer  

 

3.1 Finding your way around 

When KompoZer starts the window carries a menu bar across the top (File, Edit, View etc). 
Below this are three 'Toolbars'. To ensure that everything is visible on the Menu bar select 
View > Show/Hide and see that each of the following is checked: Composition Toolbar, 
Format Toolbar 1, Format Toolbar 2, Edit Mode Toolbar, Status bar, Rulers, Site Manager. 

The three toolbars across the top of the window carry buttons (represented by icons). Hover 
on any to find its function. If any are greyed out they are not functional in the current mode 
as they are context sensitive. 
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Across the centre of the window are two panes: the 'Site Manager' on the left and a blank 
web page on the right.  

At the top of the Page area there is a Page tab which carries the name of the page 
(‘Untitled’). (KompoZer Help refers to this as the ‘Tab Browser’ toolbar.) If you had several 
pages open, as shown in the figure, this tab would allow you to select one them rapidly. 

At the bottom of the page area is the ‘Edit Mode Toolbar’ which carries four tabs which 
select one of four ‘Viewing modes’ for a page (‘Normal’, 'HTML Tags', 'Source', 'Preview'.) 

At the bottom of the window is the 'Status Bar'. This is a very powerful tool. Once a page is 
populated, by clicking any item in the page area its structure appears on the status bar. Any 
class or id applied to an element is shown and any bearing an inline style is indicated in italic 
type. Hovering reveals the style declaration. Additionally clicking an element marker 
highlights the element in both normal view and, on changing view, in source view thus 
simplifying navigation in source view. 

Note The figure shows the buttons as they appear when KompoZer is first installed. They 
may be customised to different arrangements . If this has been done some of the following 
may be difficult to follow. To restore defaults click View > Show/Hide > Customize 
Toolbar > Main Toolbar > Restore Default Set and repeat similarly for the Format Toolbar. 
Using KompoZer right-click any toolbar to customise it. 

3.2 Starting a page 

A new page can be created either from a blank page or by opening any pre-existing page. 

Note There are often several ways of getting KompoZer to do something. This guide will 
use the button on the Composition toolbar if that is available.  

3.2.1 Document types (Doctype) 

Web pages use the HyperText Markup Language (HTML). There are number of variants of 
the basic language. KompoZer is capable of creating and editing four variants but for 
simplicity of explanation I recommend that users create the Strict HTML variant. I 
also recommend that you go the menu item Tools > Options > General and check 
the box 'Use CSS Styles instead of HTML Elements ...' this will give you the maximum 
functionality. You can edit documents which have been originated in other variants and 
again 'Use CSS Styles ...' gives maximum functionality. 

3.2.2 Options for starting a page 

There are several ways to start new pages or open existing ones. 

To start a new blank page.  

On the menu bar click File > New. 

To open an existing page.  
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Either: 

1. Click the OPEN button to access a normal browse dialogue. 
2. Click File > Recent Pages to get rapid access to those recently worked on.  
3. Or use the Site Manager) which provides a powerful mini-browser and is very easily 

set up. 

The doctype of an existing page will remain the same as before it was opened. It cannot be 
changed in KompoZer. 

Each page opened starts in a new tab which can be clicked to select a document to work on. 

3.3 Editing in KompoZer 

Tip: The plus sign (+) means that you must press two keys surrounding the plus sign at the 
same time. 

KompoZer supports all the standard Windows editing commands and shortcut keys. e.g. 
Copy Ctrl+C, Paste Ctrl+V etc. There are other KompoZer specifics. These are great time 
savers. 

In ‘HTML Tags’ view KompoZer supports drag and drop editing for block items. (Select an 
item by pressing the Control key while clicking on the Tag.) 

An extreme time saver is KompoZer’s double click response. In several cases, such as links, 
images and tables, a very useful editing window is opened. 

KompoZer supports many levels of Undo and Redo, however changes made in ‘Source’ 
view cannot be undone after you have changed the view. 

3.3.1 Saving files 

Go to File > Save as.  

You are offered a ‘Save Page as’ window which allows you to browse to the folder you 
want to use. You will find the file name already completed with your page title. You will 
probably want to change this to a shorter, all lower case, name (but you don’t have to). You 
will find the file extension completed as ‘html’ you may prefer to, and you may alter it to 
“htm”. 

Note If you have hidden extensions for file types this becomes unavailable. Hide or view 
extensions is controlled in Windows by Control Panel > Folder options > View then scroll 
down and clear 'Hide extensions for known file types'. 

After you edit files you need to re-save periodically. Click the ‘Save’ button. 

Note KompoZer includes a small red warning icon in the page tab to indicate if a page has 
not been saved.  
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There is nothing mysterious about the files. The curious may open the file using any text 
editor e.g. Windows notepad. What you will see will look just like the HTML Source code 
you’ve been looking at in ‘Source’ view. This shows that the source is just a simple text 
document.  

3.3.2 Printing pages 

The ‘Print’ button allows you to print the current page to a printer. This prints the 
page view and not the source code. 

3.4 Working with text 

3.4.1 Text on a page 

Text typed directly onto the KompoZer page defaults to appearing in the format for the 
‘body’ element. HTML defines a small number of elements specifically for text and it is 
usually preferable to use these. 

To format text in a standard element format select the text (it is actually necessary simply to 
click anywhere within the block of text) and click the first drop-down box on the format 
toolbar. This offers a selection of standard text formats. Paragraph is the most appropriate 
for general text. 

Once formatted as a paragraph, when typing in a text area, use of the ‘enter’ key starts a new 
block of text i.e. a paragraph. To start a new line within the current paragraph press 
Shift+Enter; this generates a line break. 

Other standard text formats are Heading formats from Heading 1, the largest (for the main 
heading), to Heading 6, the smallest (for the least significant). Browsers generally render 
headings in bold type. 

Text can be edited in any of the viewing modes and KompoZer responds to all the normal 
windows shortcut commands. 

3.4.2 Formatting text 

Tip: Text to be formatted may be selected in one of several ways. 

 Simply place the cursor anywhere in a block. Where the formatting desired can only 
apply to a complete block this is sufficient. 

 Double-click within a block to select a word. 
 Triple click within a block to select a line of text. 
 Drag across a section of text to highlight and select that section only. 
 In HTML Tags view press the Control key while clicking on the tag for the block to 

select the complete block. 
 Using the status bar.  
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3.4.3 Positioning text 

Generally the position of text is determined by the fact that one block flows on after the 
previous one etc. 

The space between blocks is determined by the browser.  

Paragraph and heading blocks stretch from one side of the screen to the other. This a very 
elegant way of operating. Try resizing the KompoZer window. Until it becomes so narrow 
that nothing can fit, the text reformats so that it still fits – though narrower it becomes 
longer. It is fundamental to the way the web operates that it is designed for information 
transmission and not presentation. Web design tools allow us to refine presentation but, if 
we over constrain it, we may run into problems of getting it to fit on the screen. We really 
should allow the browser as much freedom as possible. 

3.4.3.1 Fixed width text 

KompoZer allows you to constrain the width of paragraphs. (The same applies to headings.) 
Try this. Set the window size so that it is somewhat narrower than the full screen width i.e. 
so that you have space either to narrow it more or to widen it. 

Take two longish but similar paragraphs which fill about half of the window. Click in one, 
you will see the rulers both across the top and down the side. Grab the left edge of the ruler 
and draw it half way across the window. Do the same for the other paragraph but take the 
right edge of the ruler and drag it half way to the centre but in the opposite direction. 

You probably think that you’ve achieved a rather elegant layout and discovered a flexible 
tool. Drag the window to be wider then narrower. Do you still think so? What you have 
done is to set the text to be in a fixed position and of fixed width. It no longer re-flows. 
Consider that visitors who view your pages may have smallish or very large screens. Will they 
all see what you want them to? 

Tip: Instead of using HTML Tags view it is quicker just to click in the paragraph and click 
the corresponding <p> marker on the status bar. This will highlight the paragraph. After 
that just right click as described. 

Supposing that you don’t like what you have just done – you can just Undo it – press the 
Undo button or click Ctrl+Z. However if you leave it to later you would first have to undo 
all later work. You can re- or de-format a paragraph directly and individually. This allows you 
precise control rather than relying on dragging the ruler. Go to 'HTML Tags' view, click on 
the yellow 'p' marker for a paragraph, on the status bar right-click on the highlighted 'p' area 
and select ‘Inline styles’. In the general tab that appears just delete the text and click 'OK'. 
Alternatively select ‘Box Properties’. This allows precise editing of the paragraph within the 
‘box’ in which it is contained. 
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3.4.4 Lists 

3.4.4.1 Numbered and Bulleted lists 

KompoZer can format a list of items giving each item a sequential number in any of several 
formats (HTML calls these ordered lists <ol>) or presenting them bulleted (unordered lists 
<ul>).  

To start a list from scratch 

1. Click one of the list buttons (Numbered List or Bulleted list) on the Format toolbar.  
2. Type the first item. 
3. Press Enter and type the next item. 
4. To finish, on the last (blank) item press Enter 

To change existing text into a list 

1. Select the text required. 
2. Click one of the list buttons on the Format Toolbar. 

The text will be changed into a list a new item starting for each paragraph or other block 
item encountered. 

To add items to a list 

1. Click at the end of the last item in the list. 
2. Press Enter and type the new item. 

Numbering and format will continue from the previous item. 

3.4.4.2 Formatting lists 

To change the formatting for a list click in the list and, on the menu bar, select Format > 
List > List properties and choose the preferred option. Alternatively List properties is 
accessible by right-clicking in the list. 

For numbered lists the numbering style may be selected, for bulleted lists the type of bullet 
may be changed. 

3.4.4.3 Nesting lists 

Lists can be nested.  

To start a new level of list within an existing list 

1. Click at the end of the line preceding the new list to be generated. 
2. Press Shift+Enter 
3. Click a list button on the format toolbar. 
4. Type the content of each list item followed by Enter. 



    8 of 28 

Each level of list in a nested set may have either the same or different format which may be 
set as above. KompoZer sets no format by default. Browsers normally by default render all 
numbered lists with decimal number format but each level of bulleted lists using a different 
bullet symbol.  

3.4.5 Importing text 

Strictly KompoZer does not support importing text from other applications but it is possible 
to copy and paste text. 
In normal view content from other web pages may be copied reliably. The result will be 
rendered according to any styling applied in your document; any reliance on external styles in 
the original document will be lost.  
Text from word processors such as Microsoft Word or OpenOffice.org in rtf or doc format 
or from text editors such as Windows notepad may also be copied and pasted. 

Warning Word processor data should be copied in .doc or .rtf form. Word processors can 
also save pages in html form but this is unsatisfactory because the code is of poor quality. It 
will be almost impossible to alter the formats in KompoZer. To use such code first copy to a 
text editor, which removes all formatting, and then copy from the text editor to KompoZer. 
Apply any required formats from scratch. 

When such text is pasted into KompoZer most formatting is lost. 

Numbered lists will be retained. 

Tabs will be rendered as three non-breaking spaces. 

The contents of tables may be pasted, individual cells will be separated as if by tabs.  

3.5 Working with images 

With KompoZer it is easy to insert images on to your page. Browsers accept images in three 
formats ‘gif’, ‘jpg’ or ‘png’. You may have to use a graphics package to get your image into a 
suitable format. You can insert an image located anywhere on your computer but, for the 
sake of order, it is a good idea to locate any images which you intend to use either in the 
same folder (directory) as your page document or in a sub-folder of this. 

3.5.1 Inserting images 

Warning Before inserting an image save your page. Otherwise KompoZer will have 
difficulty in referencing where your image is located.  

As an exercise set your cursor in the middle of the paragraph, perhaps at the start of a 
sentence.  

To insert an image 

1. Click the 'Image' button on the Composition toolbar 
2. The Image properties window opens. Click 'Choose File' and browse and select a file 
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3. Click ‘Open’. Leave checked the box ‘URL is relative to page location’ this will allow 
you to move the page and image to another location, as you will have to when you 
upload them to a server. (If you de-select this and move the page, it will try to find 
the image at the original location.) 
Note If the box is ‘greyed out’ this is probably because the page has not been saved. 

4. In the box labelled ‘Alternate text’ add a description of the image. (This forms the 
‘alt’ attribute for the image and provides text which will appear in place of the image 
with user agents (browsers) that cannot display images (screen readers and voice 
synthesisers). It will also be used by those with visual impairment. The content of 
this box must be carefully considered so as to be of maximum assistance in such 
cases.) 
Note Where the image is purely decorative, and not necessary to understanding the 
page, alternative text is not required and should be omitted  

5. In the box labelled ‘Tooltip’ you may optionally insert a ‘Title’ attribute for the 
image. Some browsers will show the text provided when the cursor hovers over the 
image 

6. Click OK  

3.5.2 Positioning and resizing images 

You should see the image inserted into the middle of the paragraph. Maybe it has come out 
some ridiculous size. Click the image. A sizing box appears around the image. The box has 8 
graphical handles (small white squares) one at each corner of the image and one in the 
middle of each side).  

Drag on a handle to alter the size of the image. Make it some sensible size. Dragging a 
handle in the centre of a side will alter the shape of the image which is usually undesirable. 

More precise control may be achieved via the Image properties window described after the 
note. Select the ‘dimensions’ tab. 

Note Ideally images should be produced at the size required rather than resizing them. 
Importing large images and reducing the size wastes bandwidth and slows presentation. 
Resizing by small amounts can introduce undesirable artefacts. 

Tip: The method described places the image within a paragraph. You may prefer to place 
the image directly in the body area particularly if you are familiar with using styles and want 
to control the image that way. You can get directly to the body using the method described 
in the tip in section 3.16.  

Then just insert the image. 

Images in the middle of paragraphs are not usually what is needed. You can place them at 
either the right or left side and have the text wrap round.  

To align an image 

1. Click on the image. 
2. Click the Image button on the Composition toolbar: this will open the Image 

properties box.  
3. Select the ‘Appearance’ tab 
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4. In the drop down box ‘Align text to image’ select the required alignment. 
5. Click OK 

Try the various options. The text starting from where the image is inserted will wrap around 
the image. 

You may prefer the complete paragraph to wrap. Click on the image and drag the cursor to 
the start of the paragraph, or anywhere else. Moving images is easy! 

You may find the first three options confusing. They refer to the position of the text relative 
to the image NOT the image relative to the text. Specifically you will find no way of putting 
an image in the middle of the page with text wrapping around it. 

Note This type of presentation, common enough in print, is almost impossible to achieve 
using HTML even with full use of styles. 

You may decide that the image is too close to the text, that you would like more space 
around it. Again ‘Image Properties’ allows this. On the ‘Appearance’ tab set ‘Spacing’ Top 
and Bottom and/or Left and Right as required. You can also put a border of selected width 
around a image. The border will be the same colour as the adjacent text. 

3.6 Using tables 

Tables allow data – images, links, forms, form fields, other tables, text, etc. – to be arranged 
into rows and columns of cells. 

A table is basically a rectangular grid forming an array of boxes into which the data are 
placed. The rules, between cells, and the border, around the outside of the table, may be 
either visible or invisible. The boxes are called ‘cells’ and may be coloured. The grid layout 
does not have to be regular – the first row may have one cell the second four, the third 
three; however, when first inserted, it will always be regular.  

W3C recommends: 

Tables should not be used purely as a means to layout document content as this may present 
problems when rendering to non-visual media. Additionally, when used with graphics, these 
tables may force users to scroll horizontally to view a table designed on a system with a 
larger display. To minimise these problems, authors should use style sheets to control layout 
rather than tables.  

3.6.1 Inserting tables 

To insert a table 

1. On the Composition Toolbar click the Table button. The ‘Insert table’ window 
appears  

2. Leave the ‘Quickly’ tab selected and drag out a matrix then click the bottom right cell 
to define the table arrangement.  

3. The cells appear on the screen with narrow outlines  
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Note If later the table border is set to zero these outlines disappear but KompoZer in 
normal view replaces them with a red outline. This does not appear in Preview or in a 
browser. 

Tables have resizing boxes similar to those used with images 

Alternatively for more control 

1. On the Composition Toolbar click the Table button. The ‘Insert table’ window 
appears 

2. Click the ‘Precisely’ tab 
3. Specify the number of rows and columns required 
4. Specify the width of the table either in pixels or as a percentage of window size. 

Alternatively clear the ‘width’ box. This will give ‘fluid’ width which will 
automatically adjust to the contents 

5. If a border is required around the table enter the width in pixels otherwise enter ‘0’. 
If a border is specified each cell will also have a border but narrow 

For more options 

Right-click the table and select ‘Table Cell properties’. The Table properties window opens. 
This has two tabs ‘Table’ and ‘Cells’ which allow overall control of several aspects of either 
the table or individual cells. This includes  

a. Alignment of text within cells 
b. Wrapping of text 
c. Cell spacing - the gap between cells 
d. Cell padding - the gap between the edge of the cell and the text within it 
e. Size of table and cells 
f. Background colour  
g. Selection of cells as 'Normal' or ‘Header’ (Cells which are headings to rows or 

columns should be selected as ‘Header’. Normally this results in them being rendered 
in bold type.) 

3.6.2 Formatting tables 

3.6.2.1 Table size 

Tables created using the ‘Quickly’ tab have width set to 100% of the window size. 

Note Sometimes KompoZer creates tables at a different width in which case this may be 
altered as given below. 

Tables at full window width give the maximum available space for data. The width 
accommodates to screen or window size. 

It is possible to set the width to a smaller percentage of window size or to a fixed size in 
pixels. Fixed sized tables are inflexible in use and could result in the user having to scroll 
horizontally to read the content so must be used with caution. It is also possible to leave the 
width unspecified. This is likely to result in the best presentation as the browser will set the 
width to the optimal value. 
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To adjust table size, with the cursor in the table, click the table button (or double-click the 
table). In the Table Properties window select the ‘Table’ tab. The width can be set either as a 
percentage of window width or in pixels. To leave it unspecified clear any number in the 
width box. 

It is possible to adjust the size of a table using the sizing boxes. When you do this the size is 
specified in pixels. 

3.6.2.2 Colouring, adding deleting and merging cells, rows and columns 

Right-Click in a table or cell and several menu options appear which allow the table or cell to 
be formatted as desired. Some of the options are context sensitive. 

‘Table or cell background color’ allows the colour of the complete table or any cell to be set. 

‘Table Insert’ provides means of adding rows, columns, individual cells or even tables into a 
cell.  

‘Table delete’ provides the opposite. 

A cell can be joined with the cell on its right, thus merging two cells. Virgin cells cannot be 
split but joined cells can. 

If adjacent cells (whether within a row or column) are selected together they can be joined. 

Each cell, when clicked, reveals a set of six manipulation symbols (triangles and circles 
with x inside), these provide a rapid method of inserting or deleting rows and columns of 
cells as shown in the figure. 

Setting the cell background colour for adjacent cells to a dark colour reveals gaps between 
the cells. 

This may be convenient if the cells are to be filled with text as it avoids two items of text 
abutting each other. 

At other times it is a problem. The gap is controlled by the ‘Cellspacing’ attribute. 

3.6.2.3 Background images 

It is possible to set a background image for a table or cell. 

The CSS Specification in section 14.2.1 recommends  

When setting a background image, authors should also specify a background color that will 
be used when the image is unavailable. When the image is available, it is rendered on top of 
the background color. (Thus, the color is visible in the transparent parts of the image).  

The image appears behind the contents of the table. If the image is larger than the table the 
table is unaffected i.e. does not grow to accommodate the image, as much of the image as 
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will fit is displayed. If the image is smaller than the table several options are offered e.g. the 
image may be centred or tiled horizontally, or vertically or in both directions until it fills the 
table.  

To apply a background image  

1. In ‘HTML Tags’ view click the tag for the table (or cell) while pressing the control 
key. 

2. On the Status Bar right click on the highlighted tag. 
3. Select ‘Inline Styles’, ‘Background Properties’. 

You can then select the tiling and/or position properties as required.  

Note Background images are visible in Normal or Preview mode but not in HTML tags 
view. 

3.6.2.4 Setting cell border and spacing 

Right-click in a table, select ‘Table Cell Properties’ and the ‘Table Properties’ window 
appears. By selecting the ‘Table’ Tab the spacing is revealed as defaulting to 2 pixels between 
cells. If this is set to zero the gaps referred to in the previous paragraph disappear.  

Note The ‘Table Properties’ window can also be accessed from within a table by clicking the 
‘Table’ button. 

The ‘border’ defaults to 1 pixel. This border appears around the edge of the table and rules 
appear around each cell rendering the outlines easily visible. If the border is set to zero both 
border and rules disappear. 

If the border is set to a value greater than 1 pixel the rules re-appear and the border appears 
in the wider value specified. The exact appearance of the table border depends on the 
browser used. 

Other aspects of these lines e.g. colour or suppressing rules when table border is selected 
cannot be controlled using these methods. 

The ‘Table Properties’ window also allows the ‘padding’ to be set. Padding is the distance 
between the cell content, e.g. text, and the edge of the cell. This provides an alternative way 
of establishing space between the content of adjacent cells. Padding applies to all four edges 
of a cell and to all the cells in a table. Once again use a style for fuller control. 

3.6.2.5 Colouring tables 

KompoZer however provides several routes to colouring tables or cells. These include:  

 Right-click on table and select Table Cell Properties. 
 Use Table button to open Table Properties window. 
 Right-click in table and select ‘Table or Cell. Background Color’. 
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3.6.2.6 Cell sizes 

As you work on a table the sizes of the cells may keep on changing. It is useful to understand 
how browsers treat tables. Unless the size of a table or cell is constrained in some way a 
browser will expand the cell in an attempt to accommodate any text inserted. Other cells in 
the same column will have the same width. This will tend to reduce the space available for 
any adjacent column of cells. Eventually the browser will attempt to balance the allocation to 
each column by wrapping the text. The overall effect will probably minimise the total height 
of the table. 

Tables can have their width completely unspecified, specified to be a particular width in 
pixels or some percentage of window width.  

When a table is started the Insert Table automatically selects the ‘Quickly’ tab. This allows 
KompoZer to make the decisions. If the ‘Precisely’ tab is selected the user can make 
selections specifying the width in pixels or as a percentage and specifying the border width. 
Tables specified as percentage or unspecified are more accommodating to differing window 
or screen sizes and are recommended. 

Browsers do not have to slavishly follow instructions. If a table specification is too narrow to 
accommodate the cell contents the table will grow beyond its specified limit. This can occur 
if a large image is inserted or a long word like ‘Antidisestablishmentarianism’. 

3.6.2.7 Table properties 

The table properties window opens when you 

 Click a table and click the table button 
 Right click anywhere in a table and select ‘Table cell properties’. 

Tables and cells can be re-formatted in many ways. This means that you don’t have to plan 
everything in advance before you start your table as settings can be adjusted later. 

The table properties window provides an option to insert a caption which can be positioned 
on any edge. 

For those familiar with them, the ‘Advanced Edit’ button gives direct access to inline styles. 

3.6.3 Inserting Text 

Tip. Use HTML Tags view to see where to input the text. 

Inserting text into a table cell is one of the simplest of tasks. Inserted text will be formatted 
as a TD element but may be re-formatted as a paragraph or using styles. 

Even the simplest of can tasks become tedious if carried out repetitively possibly copying 
and pasting from pre-prepared text.  

After selecting a piece of text KompoZer offers a useful facility via Tables > Create table 
from selection. Lines of text (whether terminated by line breaks or paragraph ends) will be 
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converted to table rows, a new cell being generated each time the specified character is met. 
This allows tabbed lists to be created and overcomes the fact that HTML does not support 
tabs – Simply type a hyphen (or some other character) instead of the tab and convert the text 
to a table. 

Using this method tables may be imported from applications like MS Word. In Word 
convert the table to text separating using a character that does not appear in the text. 

Note Do not use tab as the separator as KompoZer will interpret this as several spaces. 

3.6.3.1 Aligning text 

Browsers normally display text aligned left and, in the vertical dimension, in then middle of 
the cell. To alter this place the cursor in a cell and click the Table button. The Table 
properties window allows the alignment to be altered. To set the alignment for all cells first 
select Table > Select> All Cells. 

3.6.4 Centring tables 

To align a table to the centre of a page click the table, right-click ‘Table Cell Properties’, 
select ‘Table’ and set ‘Table Alignment’ to ‘Center’. 

Note If you are using Nvu (not KompoZer) to create a page using transitional doctype 
Internet Explorer aligns tables left. This may be corrected by editing the code in Source view 
to precede the Table with the code <div align="center"> and follow the table with 
</div>. N.B. This code would not be valid to use for pages which have strict doctype.  

3.6.5 Improving tables 

There are a number of ways in which tables may be improved in presentation and 
accessibility. These include: 

Caption - This is text describing the nature of the table. Insert this using the Table 
Properties window. The caption may be positioned on any edge of the table. 

Summary - Captions will often be inadequate as a summary of the purpose and structure of 
the table from the perspective of people relying on non-visual user agents. W3C 
recommends “Authors should therefore take care to provide additional information 
summarizing the purpose and structure of the table using the summary attribute of the 
TABLE element. This is especially important for tables without captions.” To add a 
summary, in the Table Properties window, select the Table tab and click the Advanced edit 
button. On the HTML attributes tab select the Summary attribute and insert the text in the 
‘Value’ box. 

Headings - Headings to rows and/or columns improve the visual presentation and make 
the meaning of the content clearer. By default headings are displayed bolder and centred. 
Headings are implemented in HTML by replacing td (table data) elements by th (table 
header) elements. To change a cell from td (normal cell) to heading select the cell and, using 
the Table Properties window, with the ‘cells’ tab selected tick the ‘Cell Style’ checkbox and 
set the style to ‘Header’. 

http://www.charlescooke.me.uk/web/ugs03.htm#s3627
http://www.charlescooke.me.uk/web/ugs03.htm#s3627
http://www.charlescooke.me.uk/web/ugs03.htm#s3627
http://www.charlescooke.me.uk/web/ugs03.htm#s3627
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Accessibility - Adding summaries and headings represents the first step in improving 
accessibility of tables to non-visual users. HTML offers more powerful enhancements which 
improve the performance of text to speech devices. For more details about this see section 
11.4 of the HTML 4.01 specification. 

3.7 Links 

Links provide the main means of navigating web sites. They allow you to move quickly from 
one place to either another on the same page, a different page on the same site or a page on 
an external site. Links may be attached to any element on a page, in fact almost any part of a 
page content can form the basis of a link an element being generated specifically for the 
purpose. Usually however we use a few words of text or an image which we click on to 
activate the link. 

3.7.1 Linking text 

3.7.1.1 Linking to another file 

To create a link 

1. Select (highlight) a few words of text  

2. On the Composition toolbar click on the ‘Link’ button, alternatively Right-click 
and select ‘Create Link’. The ‘Link Properties’ window opens 

3. Click on ‘Choose File’ and browse to the file that you want to link to 
4. Click OPEN 
5. Click OK 

In Normal or Preview mode you will now find your text underlined and in a different colour 
(probably blue) You can now try double-clicking on the text, you will see the ‘Link 
Properties’ pop up again. This can be very useful if you want to change the file to which the 
link refers. (In a browser you would expect the file viewed to be replaced by the one to 
which the link refers!) 

If you now switch to ‘HTML Tags’ view you will see your text preceded by a yellow marker 
with an ‘A’ in it. Your text has been defined as an ‘A’ (Anchor) element. 

3.7.1.2 Inserting an email address 

Instead of linking to a file it is possible to insert an email address. The result will be that, in 
use, when the link is clicked the email client on the visitor’s machine will be opened with the 
correct address selected. 

To do so proceed as under the previous heading. When the Link Properties window opens 
(or if Image Properties click the Link tab) enter the email address and check the box ‘The 
above is an email address’  

http://www.charlescooke.me.uk/web/uga1.htm#a2


    17 of 28 

3.7.1.3 Inserting named Anchors 

There is a second type of Anchor element the ‘Named anchor’. Such an anchor is extremely 
useful as it can act as a type of bookmark defining a particular place on a page. Links can 
jump to such bookmarks. 

To insert a named anchor  

1. Place the cursor at the point you want to mark. 
2. Click the ‘Anchor’ button on the Composition toolbar or, on the Menu Bar, select 

Insert > Named Anchor. The named anchor properties window appears. 
3. Enter a unique name for the anchor. 
4. Click OK.  

In ‘Normal’ view anchors are marked by a picture of an anchor . 

3.7.1.4 Linking to named anchors 

Tip. If you have organised your page well using headings when appropriate KompoZer 
makes linking to places on a page extremely easy. Even if you have not inserted an anchor 
choose the drop down list as described. All headings will be included in the list and clicking 
on one will simultaneously create the anchor and link to it. 

Start as above for linking to another file. When the 'Link Properties' window opens, instead 
of choosing file use the drop down list. Your anchor name should appear there preceded by 
a “#”. Click it and OK. That’s it! If you test your page on a browser when you click the link 
the view should move to show the position of the anchor. 

Note If your page is short you may not notice this. You need to test with a long page with 
the link towards the bottom and the anchor towards the top. With most browsers the anchor 
should be sit on the top visible line. 

3.7.1.5 Link colours 

Links are normally underlined and in blue text. If you look carefully you may see the colour 
change and wonder why. Links can exist in several states the principal are:  

unvisited links the initial state 

visited links have been visited in the past 

hovered cursor now hovering over 

While these probably appear in different colours it is the browser which determines this. 

Note For Transitional doctypes KompoZer offers a means of altering the colours via Tools 
> Options > New Page Settings. All new pages should use the new selections (they don’t 
affect the currently open page). A better way to gain full, reliable control is to clear ‘Use 
custom, colors’ and set link colours using styles.  
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3.7.2 Linking images 

The techniques and possibilities are very similar to those used with text. 

To create a link 

1. Click on the image  
2. On the Composition toolbar click on the ‘Link’ button, alternatively Right-click and 

select ‘Create Link’. The 'Image Properties’ window opens 
3. Click on ‘Choose File’ and browse to the file that you want to link to. (The box ‘URL 

is relative to page location’ is checked. This means that if you move your page to a 
new folder you should move the image to a corresponding new folder. If you clear 
this box the absolute address of the image on the hard drive is given in full. If you 
move your page now it will look there for the image. As you start to organise a web 
site you will find that this is not a good arrangement and potentially disastrous when 
you upload the page to a server.) 

4. Click OPEN 
5. Click OK 

3.7.3 Editing Links 

To change the file to which a link refers, in Normal, Tags or Preview mode double-click on 
the link. The ‘Link properties’ window opens (for an image the ‘Image Properties’ window 
opens - click the Link tab). Edit the link. 

To remove the link delete the link reference in the box.  

3.8 Forms 

3.8.1 Introduction 

Forms provide a mechanism by which a visitor to a site may send data to as sever for 
processing. This may be as simple as a box to write a message for e-mailing or as complex as 
looking up items from a catalogue and sending an order to a supplier. Forms collect data 
typed in or collected from check boxes or lists and pass them to the server. It follows that 
forms can be used only in association with compatible software running on the server. 

Forms may be placed on standard web pages and act as block level elements. In normal view 
KompoZer shows forms surrounded by a dotted cyan box. Forms may contain other 
standard block level elements (paragraphs, headings …) as well as several specific elements 
known as ‘form controls’ which are designed for data collection. Since these form controls 
are essentially inline elements they must be laid out inside block level elements (typically 
paragraphs though divs would be equally suitable). 

Each item of data sent to the server is tagged with information about which control has sent 
it. This is done by naming each control. Thus designers must give a unique name to each 
control to be used. 

The data collected by a form will be sent to a URL specified in an element ‘action’ which 
KompoZer will add to the form. This URL is often on the server that hosts the web page 
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but does not have to be. The data will be processed using one of two methods known as 
‘GET or ‘POST’ which also need to be specified. These details will be available from the 
provider of the associated software. 

3.8.2 To set up a form 

1. Click the form button. 
2. In the Form properties window give the form a name of your choosing 
3. Complete the Action box with the correct URL and select the appropriate method 
4. ‘Encoding’ and ‘Target Frame’ will frequently not be required but, if they are, select 

‘More Properties’ and complete the boxes 
5. Click OK  
6. On the form place any headings, paragraphs and images ensuring that there is a 

placeholder for any controls needed. (If blank placeholders are needed it is probably 
sensible to put some dummy text in now and delete it later.) 

7. Where controls are needed click the corresponding placeholder and using the drop 
down box beside the Form button select the required control 

8. Give each control a unique name 
9. Each control has specific information which needs to be entered. Enter it into the 

box in the window which appears 

Note Since this is a guide to using KompoZer and not to designing forms this is as far as we 
go.  

3.8.3 Form control styles 

If the standard form styles do not appeal it is possible by the use of styles to customise them 
to personal preferences.  

3.9 Layers 

3.9.1 What layers are 

One of KompoZer’s ‘Tip of the day’ says “Did you know that … you can move 
elements? Just place the caret in the block you’d like to move and click once on the Layer 
button to make the block movable.” 

Items forming layers are taken out of the normal document flow and placed in positions 
defined on the page absolutely e.g. in positions fixed relative to the page boundary. 

While layers introduce a level of flexibility to page design they also involve complexities that 
newcomers may wish to avoid. This section is therefore for those who wish to delve further.  

3.9.2 Creating layers 

To create a layer. 

1. Click in the block that you want to format as a layer. 
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2. Click the layer button on the Format (2) toolbar. 

The block becomes a ‘Layer’. Layers have sizing boxes which 
allow the size to be altered. At the top of the layer is a positioning handle (denoted by a four-
way arrow) . To move the layer click and drag the handle.  

Layers do not have to consist of a single block – any sequence of elements that can be 
selected together can be converted into a layer. This may be several paragraphs with or 
without headings, images and tables.  

Layers allow items to be placed on a page so that the absolute position, relative to the page, 
is defined. This provides a facility common in drawing and desk top publishing programs 
and allows items to be overlaid on top of each other. As such it is a very powerful tool.  

Text items normally have transparent background so when overlaid become confused. By 
formatting them with a background colour they become solid. Similarly tables with solid 
background and non-transparent images may be overlaid on each other to produce clear 
effects. 

3.9.3 Characteristics of layers 

Items converted to layers have several characteristics which differ from ‘normal’ items.  

 Layers in KompoZer are contained in ‘div’ elements.  
 Layers break out of the normal flow in which each block follows the previous and 

precedes the next. 
 Layers, as created by KompoZer, have defined width so do not accommodate to 

narrowing or widening the viewing window. 
 Layers do not however have defined height so will accommodate to changes in text 

size selected in the browser. 
 Layers, as created, are characterised by three parameters ‘top’, ‘left’, and ‘width’. 

These define, in pixels, how far the top left hand corner of the layer is from the top 
left hand origin of the page and how wide the layer is. 

 Layers may be manipulated using the buttons on the Format 2 toolbar. 

3.9.4 Manipulating layers 

To move a layer click the positioning handle and drag it to the required position on the page. 

To resize a layer drag a sizing handle as for other elements.  

When positioning a layer, KompoZer allows pixel-accuracy movement. This can be difficult 
to achieve and, if it is attempted to line up items, small errors may become obvious. Better 
results may be achieved by snapping positions to a coarser grid. To do so select Format > 
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Positioning grid and set the granularity required. Movement will now be constrained to the 
selection made. 

Note This setting must be set each time a page is opened. It is not remembered.  

Note Snapping applies to dragging the position not the size. 

Warning If several overlapping layers occur on a page it may become impossible to click on 
a handle. In this event try resizing it so that the handles become accessible, alternatively 
temporally move another layer out of the way.  

Note If the height of a layer is dragged, though previously undefined, it becomes defined 
but the contents will overflow so there will be no visible change. 

When positioning layers so that they overlap a mechanism is needed to define 
which is in front (so entirely visible) which behind (so partially obscured). Two buttons 
(‘Bring to front’ and ‘Send to back’) on the Format 2 toolbar take care of this. Select the 
layer and click the appropriate button. 

Layers, as created, do not have a property 
‘z-index’ allocated. When brought to the front a z-index with value =1 is attached. The z-
index defines how far forward the layer is. If another layer is to be brought to the front of 
the first it needs z-index to be set to 2. Selecting it and bringing it to the front however 
merely sets the index to 1. By repeating the process the index is set to 2 and the layer 
brought further forward.  

Note The buttons would be more appropriately labelled ‘Bring forward’, and ‘Send back’. 

3.10 Borders 

Elsewhere a number of methods for applying borders to images and tables have been 
mentioned. The level of control possible has varied from case to case and the use of style 
sheets to gain full control has been referred to. 

There is one further method which is very easy to apply and which is applicable not only to 
single elements (e.g. Table (and/or cells), Image, Heading, Paragraph, Form) but also to a 
group opf elements. 

The method uses the full border capabilities of CSS which provides complete control of  

 Colour of the border 
 Thickness (width) of the border 
 Style – Solid, dotted, dashed, double etc. 
 Different choices for each side 
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The method does not cover other options which are sometimes available elsewhere e.g. 
Padding. 

To apply a border select a block or highlight a group of blocks, then and click the 
‘Borders’ button. 

Note The Borders button is not installed by default. To access it customise the Format 
Toolbar. See section 9.3 

Leave the check box ticked and set the style, width and colour for the top border. If all 
borders are to be the same click ‘OK’ otherwise clear the box and edit the settings for the 
other sides. 

3.11 The Body 

This is the background on which the whole page sits. The Body may be thought of as the 
Page itself. Normally it is of little concern to the designer but there are a few situations when 
it is. 

The body can carry a background colour or image which lies behind everything else on the 
page in HTML documents (in XHTML documents, the background content for the body 
element defines only the background for the body element.).Thus the overall appearance of 
a page can be significantly determined by this content.  

To set a background 

1. On the Status bar click the <body> marker. All the contents of the page will be 
highlighted. 

2. Right-click and select ‘Inline Styles’ and ‘Background properties’. 
3. Make the desired selections and click OK. 

The ‘Inline Styles’ allows you to set several other properties for the whole page. This 
includes Text, Border and Box properties. This can be a quick way of styling a whole page 
since Text properties, for instance, will trickle down (technically they are ‘inherited’) to 
everything on the page for which they are not otherwise specifically stated. Border and box 
properties are not inherited. 

Stylesheets often set several general properties for the body to avoid having to repeat them 
several times. 

Inline styles may set the body width to be less than the full window width. In this case it may 
be desired to centre the page in the window. 

To centre a page in the window 

1. On the Status bar click the <body> marker. All the contents of the page will be 
highlighted 

2. Right-click and select ‘Inline Styles’ and ‘Box properties’ 
3. In the ‘Width’ box select the width desired for the page 

http://www.charlescooke.me.uk/web/ugs09.htm#s93


    23 of 28 

4. In the ‘Margins’ area in both ‘Left’ and ‘Right’ boxes type ‘auto’ 
5. Click OK 

Note If you are using Nvu (not KompoZer) to create a page using transitional doctype in 
Internet Explorer 6 it will not centre.  

3.12 The Head area 

Every HTML document starts with a “Head” area. This provides information to browsers, 
search engines etc but is invisible on the page. 

3.13 Editing in Source view 

This mode is intended for those confident in coding in HTML. In this mode KompoZer is 
not simply a text editor. On switching to a different mode KompoZer carries out checks to 
ensure that the code is valid. If not it ‘fixes’ it. It will have made its best guess at what was 
intended – if it gets it wrong there is no going back – no ‘Undo’ button. While this may 
sometimes save you a lot of typing, if you know what you are doing, it is also possible to end 
up with a heavily ‘messed up’ page – it will display but half the content could have 
disappeared. 

Needless to say good backup practice can save many disasters. The Site Manager is actually a 
convenient tool for doing this. Create a backup folder and ‘Publish’ to this ! 

If you select an element via the status bar (see next section) to highlight it, on switching to 
source view the corresponding code will also be highlighted. This makes it possible to locate 
code very easily. (For an image the cursor will be adjacent to the code.) 

The line numbers which appear are an editing convenience, they form no part of the code. 
They can help to find your place when switching modes. When switching between 
applications the numbers are only an approximate guide.  

4    Inserts 

The menu command Insert provides several options.  

Horizontal line. Inserts a horizontal line across the width of a block at the point selected. 
This doesn’t have to be in the simple default style you can define a class and apply it to 
customise the line. Alternatively the Horizontal Line Properties (double click on the line) 
allows the width and height, alignment to be set. Colour can be set via the Advanced 
Property editor using the ‘Inline Styles’ tab and setting a value for ‘background-color’.  

Characters and symbols. Provides a wide range of characters not readily available from the 
keyboard including accented and copyright.  

Table of contents. Inserts a table of contents, based on heading styles which can be 
selected. The table entries are linked to the corresponding headings.  

http://www.charlescooke.me.uk/web/ugs08.htm
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Smart Widgets. If you’re proud of your design and that fact that KompoZer 
helped you, insert an image and a link to publicise it.  

Templates.  

HTML. Allows you to insert some hand-coded HTML code at any point on a page. (If you 
want to add code in the HEAD area you’ll have to use “Source” view instead.) 

Note If you wish to insert HTML into your page this is probably the safest way to do so. 
While you can still make mistakes in the code KompoZer will carry out some checks and 
ensure that the result is valid HTML (whether or not what you intended). Editing in Source 
view can cause massive corruption of your page.  

Break below images. If you have an image aligned right or left (with text wrapping around 
it) this command breaks the wrap at the point selected, the text continuing below the image.  

5    Site Manager  

5.1     Overview  

The site manager allows you to navigate your site or between sites easily.  

To toggle the Site Manager on or off either press F9 or use View > Show/Hide > Site 
Manager.  

Site Manager can deal with sites irrespective of whether they reside on a local machine or on 
a remote server. In the latter case, if you are on a dial-up network, Site Manager will dial and 
make the connection for you. Since generally you will set up a site on a local machine and 
later 'publish' to a remote server we will deal first with setting up on a local machine.  

Site Manager provides a directory tree view of a site similar to the view with Windows 
Explorer. It however lists only directories which you have specifically set up as ‘Sites’. You 
can set up many sites, they appear in Site Manager irrespective of where they appear in a 
normal directory tree.  

http://kompozer.net/
http://kompozer.net/
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5.2 Setting up sites  

 To set up a new site (assuming that pages for the site have already been created) open Site 
Manager, click ‘Edit Sites’. This opens the ‘Publish Settings’ window.  

Choose a convenient name for the site (You may like to call it something like “My Site 
Local” to differentiate it from a later “My Site Remote”) and enter it in the box ‘Site Name’.  

In the ‘Publishing server’ area click ‘Select directory’ and browse to the folder where the site 
is located, select the folder and OK. The box should read something like 
“file:///C:/Documents .... “ (Ignore the hint line which applies to remote sites only.)  

Leave the other boxes (Web site information, User name etc.) blank.  

Back in Site Manager in the column headed ‘Name’ the new site should be listed and can be 
expanded to show its contents.  

5.3     Site Manager Functions  

The main window lists all sites which have been set up and, for any sites which have been 
expanded, the files contained in it. (See figure.) 
Double-click any site to expand it.  

At the top of the Site Manager window a drop down box allows you to view all files or to 
select to view only html files (which includes htm files) or only image files (these include gif, 
jpg, jpeg and png files).  
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For files it is possible to display the file size and modified date. To select or de-select these 
options, in the column heading click the right-most division and select the options required 
(see figure). (You may have to widen the site manager window to make this possible.) 
It is not possible to change the order of the listing.  

Double click on any html file to load it 
directly to the page area for editing. 

By using the buttons at the top of the Site Manager window, and selecting a file if required, it 
is possible to  rename and delete files and to create folders.  

Note all these actions alter the actual files concerned. By using the ‘Edit Sites’ function and 
the ‘Publish Settings’ window, sites may be removed from the Site Manager but this has no 
effect on the actual folders or files involved only on the view in Site Manager.  

5.4     Remote sites  

Remote sites – on the server hosting a site – may be set up in almost exactly the same way as 
local sites .This permits the same browsing, display and editing functions as for a local site.  

This time all the boxes on the ‘Publish Settings’ window must be completed. Hints are 
provided for the content of each. The HTTP address will be used by the Site Manager to 
find the site.  
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Glossary 

This Glossary defines terms as used in this document. As far as possible, when terms used 
also occur in the HTML or CSS specifications, they have the same meanings as in those 
specifications. In such cases more precise definitions may be obtained there. 

ASCII 
American Standard Code for information Interchange. Defines a set of 95 printable 
characters. 

BMP 
Basic Multilingual plane. 

Button 
A small picture, or icon, which when clicked results in an action. KompoZer buttons 
are of various shapes. 

CaScadeS 
The CSS editor that comes with KompoZer. 

CSS 
Cascading Style Sheets. 

Declaration 
The second part of a style rule. Contains format details of the style. 

Deprecated 
A feature marked as deprecated is one which is considered obsolete, and whose use 
is discouraged. Generally CSS provides better features. Transitional Document types 
allow the use of deprecated features. (The ‘Strict’ type does not.) 

Directory 
Equivalent to what Windows calls a ‘folder’. 

Doctype 
Document type Declaration -  

DTD 
Document type Definition -  

Element 
A small part of a web page such as a paragraph or an image which can be 
manipulated by a browser in ways determined by the code associated with the 
element. 

Extension 
The final section of a filename (after the dot) indicating the type of file. 

FTP 
File Transfer Protocol. Used to transfer files to a server. 

Handle 
Symbols, usually small squares, on the edges of sizing boxes which, when clicked, 
allow the size or position to be dragged. 

HTML 
HyperText Markup Language. The publishing language of the World Wide Web. 

ISP 
Internet Service Provider. 

KompoZer 
The open source software package available at http://kompozer.sourceforge.net/, 
on which this guide is based. 

Mozilla 

http://kompozer.sourceforge.net/
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I use the term to refer to a number of similar browsers including Netscape 6 and 
later, Mozilla and Firefox. 

MSIE 
Microsoft Internet Explorer. The browser from Microsoft Corporation. 

Non-breaking space 
A space character which, though invisible, acts as a normal character in that a ‘word’ 
which includes a non-breaking space will not be split to wrap a line. 

 
Quirks Mode 

For documents with transitional doctype MSIE offers two modes of operation — 
'Standards mode' and 'Quirks mode'. In quirks mode it emulates the behaviour of 
MSIE5. Quirks mode is triggered when the doctype does not comply with the 
specification and omits the DTD. 

Selector 
The first part of a style rule. (May be thought of as the name of the rule.) 

Sizing box 
A box, denoted by small squares, (Handles) which in KompoZer appears around 
some items when clicked. See also ‘Handle’. 

Strict 
see ‘Deprecated’. 

Stylesheet 
A text file, that may be a part of the page in use, that describes the position, 
appearance or behaviour of some or all of the html elements of which the 
page consists.  

Tab (window) 
Part of many window structures which emulate the tab on a paper filing system 
designed to give quick access to part of the file. If a tab is clicked a new display will 
appear within the same window. 

Tab (key) 
The keyboard key intended to emulate the action of the tab key on a typewriter. 

Tag 
A piece of code in a web page associated with an element. Typically each element has 
a start tag and an end tag. Tags include the element name and are surrounded by 
angle brackets. E.g. <p> and </p>. 

UCS 
Universal character set. A set of about 100,000 characters. 

Upload (ing) 
The process of transferring web files from a local computer to the computer which 
will host them on the web. 

URL 
Uniform Resource Locator. The web address of an item. 

W3C 
World Wide Web Consortium http://www.w3.org/ A consortium of the 500 biggest 
IT corporations who got together to define specifications and recommendations so 
that languages like HTML or CSS can inter-operate without problems on different 
platforms, devices, operating systems and media. 

http://www.w3.org/

